Dodge Caliber Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
ok so im new here trying to repair my weird issue
my running light/turn signal and headlight on passenger side quit at the same timesounds standard change bulb ect but wait heres the truely odd part
when i unplug the headlight and liggle the wire the running light turns back on BUT if i start my car it turns off regardless of headlamp being in it or on
and when this started to happen my brake warning light on the dash is on(not blinking)
any suggestions on where to go from here??
 

·
Super Moderator
Joined
·
12,594 Posts
You probably just pulled on a ground point, corrosion weakens them.
 

·
Registered
Joined
·
860 Posts
There's a major grounding point for ~8 different electrical circuits behind the passenger side front headlight...it's probably bad and in need of repair. I have a video on YouTube that shows where it is and how you can fix it.
 

·
Registered
Joined
·
860 Posts
Ground wire issues are actually rather common, especially here in the rust belt. The winter road salt mixes with water, turns to brine, gets sprayed all up into the car, and the salt water eats the copper alive. Chrysler grounding multiple circuits to a single grounding point doesn't help the situation. Still, better a grounding point than a failed $800 module ;)
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #11 ·
Ground wire issues are actually rather common, especially here in the rust belt. The winter road salt mixes with water, turns to brine, gets sprayed all up into the car, and the salt water eats the copper alive. Chrysler grounding multiple circuits to a single grounding point doesn't help the situation. Still, better a grounding point than a failed $800 module ;)
indeed rust belt blows
 
1 - 11 of 11 Posts
Top