Dodge Caliber Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am hoping someone can help me. I have a 2007 Caliber that neither the right or left turn signals are working on. It started with the left turn signal yesterday. Thought maybe I had a burnt out bulb so I bought replacement. The turn signal still did not work after I replaced it. Now today the right turn signal is out. The indicators on the instument display in the car blinks rapidly when ever either turn signal is activated. I was thinking it was a blown fuse but I am not sure what fuse to even check. The owners manual does not say exactly which one(s) it is and I am a little confused.

Any help or suggetions would be greatly appreciated
 

·
Registered
Joined
·
3,985 Posts
I am hoping someone can help me. I have a 2007 Caliber that neither the right or left turn signals are working on. It started with the left turn signal yesterday. Thought maybe I had a burnt out bulb so I bought replacement. The turn signal still did not work after I replaced it. Now today the right turn signal is out. The indicators on the instument display in the car blinks rapidly when ever either turn signal is activated. I was thinking it was a blown fuse but I am not sure what fuse to even check. The owners manual does not say exactly which one(s) it is and I am a little confused.

Any help or suggetions would be greatly appreciated
There are no fuses in the Caliber.

If the blinker goes rapidly, it's because one of the bulbs is blown or the wire that goes to it is severed, causing more power to redirect to the remaining bulbs and tripping the relay faster.

If bulbs or wires are not at fault, then you'll need to have your power module checked.
 

·
The Organizer
Joined
·
15,005 Posts
This is not fuse or bulb related. It sounds like the TIPM is acting up. The dealer will have to look at it and reset it. You have no choice in the matter.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Thanks for the replies. I replaced both of the turn signal light bulbs for the back of the car. According to the owners manual, it says if there is a problem with the front lights you have to take it to the dealers.

Does anyone know if the front lights are available only thru the dealers and that is why they say that? Just curious.

Either way looks like I have to make a trip to the dealers or an auto repair shop. I will be making an appointment in the morining.
 

·
The Organizer
Joined
·
15,005 Posts
Thanks for the replies. I replaced both of the turn signal light bulbs for the back of the car. According to the owners manual, it says if there is a problem with the front lights you have to take it to the dealers.

Does anyone know if the front lights are available only thru the dealers and that is why they say that? Just curious.

Either way looks like I have to make a trip to the dealers or an auto repair shop. I will be making an appointment in the morining.
The fronts are accessible by removing the fasteners that hold the wheel wells in place. You can then hold it out of the way and reach in to remove the bulbs. I suspect this is the TIPM that is the problem. The lights are controlled through the computer which sends a signal to the TIPM to then turn the light on. Since none are working, either the TIPM sensed a problem, or the TIPM is at fault, and in either case it will require the dealer to reset the system.
 
G

·
Turn signals on 2007 Didge Caliber SXT

I was hoping, even though this thread is very old, that you could tell me what ended up with the turn signal problem. I have the exact same thing going on with my 2007 SXT right now. First the left turn signal went out and then the right. Also, my car lost power randomly when I hit the electronic "lock" button on my key and then came back on two minutes later.

Anyway,

Any responses would be appreciated.

Thanks

Jeremy
 

·
The Organizer
Joined
·
15,005 Posts
I was hoping, even though this thread is very old, that you could tell me what ended up with the turn signal problem. I have the exact same thing going on with my 2007 SXT right now. First the left turn signal went out and then the right. Also, my car lost power randomly when I hit the electronic "lock" button on my key and then came back on two minutes later.

Anyway,

Any responses would be appreciated.

Thanks

Jeremy
Have you ever had the software updated? Has the battery ever been replaced?
 

·
The Organizer
Joined
·
15,005 Posts
I just got the car in June, so no. Is the software update something that a dealer has to do?
Yes. Many people never have enough reason, or for that matter, even know that they should have the dealer periodically update the software on their car from time to time. The 2007s, because they were a first year car, had many software updates for both the engine computer and transmission computer. The dealer can check to see what software updates are needed using your car's VIN.
 

·
Registered
Joined
·
1 Posts
Hey, I'm not sure if you found a cure for your 07 light issues. I too had a pickle. I changed all the bulbs on the right side and I still got that fast blink. So I took the sockets out of the wires and switched for the left side. (all 3 plugs) and the problem still persisted with the right side blinking fast. We then looked at the ground as power was getting back to it, but it seemed like something was up with ground. Cut all 3 ground wires to all 3 plugs on the right side, then took the ground from the plugs itself and made a ground post close by to the body (behide right tail lens) connected all 3 grounds to new ground. Problem solved. Reverse didn't strobe, blinker didn't dim and tail light stayed lit when pressing the pedal. George, you are a Genius !!
The Dodge dealer of course was telling me I needed a Computer Module. $1200.00 plus labor, which I wasn't sticking around to find out the cost of labor. George spent $6 on shrink tubes and a bit of wire.
It just turned 200000km and it still drives like new.
 

·
Registered
Joined
·
1 Posts
Hey, I'm not sure if you found a cure for your 07 light issues. I too had a pickle. I changed all the bulbs on the right side and I still got that fast blink. So I took the sockets out of the wires and switched for the left side. (all 3 plugs) and the problem still persisted with the right side blinking fast. We then looked at the ground as power was getting back to it, but it seemed like something was up with ground. Cut all 3 ground wires to all 3 plugs on the right side, then took the ground from the plugs itself and made a ground post close by to the body (behide right tail lens) connected all 3 grounds to new ground. Problem solved. Reverse didn't strobe, blinker didn't dim and tail light stayed lit when pressing the pedal. George, you are a Genius !!
The Dodge dealer of course was telling me I needed a Computer Module. $1200.00 plus labor, which I wasn't sticking around to find out the cost of labor. George spent $6 on shrink tubes and a bit of wire.
It just turned 200000km and it still drives like new.
Welp! I started out with the left fast blinker problem, and now the headlamp on that side stopped working as well. I've been reading through forums forever and I'm going to give this a shot too.
I swapped the headlight assemblies to test, and the right side works with both.
A couple of my relays were corroded horribly, and I just finished putting new connectors in the relay block, as well as a few new wires and relays.
ObiTom you're my only hope.
 
1 - 12 of 12 Posts
Top