Dodge Caliber Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey Mouser ( or anyone else that may know )

I've looked everywhere on here and can't find my specific answer and it seems like you are the guy to ask so here I am.

I've got a 08 CSRT with a K&N Air Filter, AGP Wastegate Actuator, new Iridum Plugs Gapped @ .038, and currently running 91 diablo tune. (Problem occurs with 93 diablo tune as well.)

I'll see if I can explain this well. In any gear if I accelerate hard the boost will come up and then hit a certain point (about 17-20 psi I think) where I'll get a nasty stutter, like a bucking sensation. If I come up slowly I don't get it. It's like I'm bouncing off the boost limit ? I thought perhaps it was my agp wastgate actuator being adjusted wrong as it was just installed? When trying to adjust it out on the actuator, I did get a CEL for misfire Cylinder 3. I tested for boost leaks yesterday and think I got them tidied up, but still not better.

What are your thoughts? Coil?

Thank you for this and for all of your other contributions on the forum, they have been super helpful.
 

·
Super Moderator
Joined
·
12,269 Posts
Mouser has not been on this Forum for 7 years though his old contributions are appreciated. No idea if he still runs an SRT. They are rare and even rarer on this Z. With the expiry of other CSRT4 groups we do have a couple of active drivers. You may want to reach out to them, even start up a Special Interest Group.
 
1 - 2 of 2 Posts
Top