Dodge Caliber Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello, to all. I having an issue with my Caliber and wish someone could help.

So I have a 2012 Caliber SXT 2.4L, with 78K miles in it. The problem is it cranks and doesn't start, then after several tries it starts.
Sometimes it doesn't have a problem in the day. Then the next day it stalls with the ETC light coming on, and goes to limp mode, other day it just turns the motor off
with no power at all driving it. I have changed the PCV Valve, the 4 ignition coils, cleaned up the Throttle Body, the battery is OK (voltage/amperage) and still keeps randomly making this type of failures.
Any idea? Anyone that can help or guide? Or someone that went through the same issues? Thanks a lot for reading!
 

·
Registered
Joined
·
86 Posts
Do you live in a region where corrosion or rust is an issue? Maybe check all the engine grounds?

Otherwise, consider paying the dealer or an independent shop to at least diagnose the issue.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thank you John for your reply, I'll check the grounds. I live in dry weather almost all year, so I don't think rust is an issue.

Do you live in a region where corrosion or rust is an issue? Maybe check all the engine grounds?

Otherwise, consider paying the dealer or an independent shop to at least diagnose the issue.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
HI Chris. No CEL on, no codes. Just cranks no starting. And in another case, it went off driving the car, it kept power to all accesories and lights.
Like in another posts that I have read, first thing in the morning starts, then i get to work and park it and try to start again and the problem begins. Cranks but no start, something is preventing to start when the engine is warm.

Does the Check Engine light come on and have you scanned the car for any error codes?
 

·
Registered
Joined
·
595 Posts
I started having a similar issue at one point...would be hard to start under certain circumstances. Turned out that there's something amiss with the EVAP system and it would start doing this when the gas tank was full. I simply stopped filling it up completely and only filled it 3/4-7/8 full and the problem hasn't reoccurred. Easier than actually trying to diagnose it, lol!

You could have some sort of fuel related problem (like this issue, or a weak fuel pump or whatnot) as well. Something to check anyway.
 

·
Registered
Joined
·
1 Posts
Hello, to all. I having an issue with my Caliber and wish someone could help.

So I have a 2012 Caliber SXT 2.4L, with 78K miles in it. The problem is it cranks and doesn't start, then after several tries it starts.
Sometimes it doesn't have a problem in the day. Then the next day it stalls with the ETC light coming on, and goes to limp mode, other day it just turns the motor off
with no power at all driving it. I have changed the PCV Valve, the 4 ignition coils, cleaned up the Throttle Body, the battery is OK (voltage/amperage) and still keeps randomly making this type of failures.
Any idea? Anyone that can help or guide? Or someone that went through the same issues? Thanks a lot for reading!
Also have a 2012 caliber just like yours experience the same issue after everything all the hundreds of dollars and the dealer saying it was wasn't recognizing the key and it had unhooked the battery for 5 to 10 minutes and hooked it back up and it reset computer and everything supposedly a fault in the security system so if it does it again after doing that then just turn it right back off wait 5 minutes and try to start it again
 
1 - 7 of 7 Posts
Top