Dodge Caliber Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey I recently had HID 10k installed single beam for my headlights and also for my fog lights they were working great for about 3 days. Then as I was walking out of my house I pressed the unlock button key and the car started to attempt to turn on by its self. I got in and turned on the car with the key it seemed to be fine, but since I was about to travel about 40 mins away. I decided to pull over and check what was going on. The car started to attempt to turn on buy its self once again until it ended up smokeing. I had the car towed and serviced at the dealer. They said it was because of my HIDs and that there may be internal damage to my cars TIPM because of my HIDs. How could this be if HID run on lower current and power then factory light settings?They advised me that I should disable my hids. The same day I got my car when I was leaveing the dealer I turned on my car every thing was normal, but as soon as I turned on my lights the starter started to make noise until I disconnected the hid positive from the battery have had no problem since then, but I do miss my HIDs and want them back on still have my fog lights tho what should I do? What could be the problem?
 

·
Registered
Joined
·
4,158 Posts
Welcome to our Caliber family caliRT24. I'm sorry but i don't know how to help you on your problem, someone will probably know and post later.
 

·
Registered
Joined
·
195 Posts
Hello and welcome caliRT24, :wave: to the best Caliber forum on the net.
There is a lot of information and great members here.

Enjoy the forum & your ride. :Racing:
 

·
Administrator
Joined
·
10,855 Posts
Try buying a set form Xflashjr, a supporting vendor here. They have worked out the bugs on the Caliber with HID's.

Here is the headlights supercenter forum>>>> http://www.caliberforumz.com/forumdisplay.php?f=86

If your other set of hid's caused you that trouble, I wouldn't use them again, or at least make sure something wasn't installed improperly first.
 

·
Administrator
Joined
·
6,493 Posts
Welcome to the forum! Hope its taken care of quickly! :wavey:
 

·
Registered
Joined
·
9,770 Posts
Welcome to the forumz! I'd go back to the installer and try to find out what they did. It's pretty obvious that they didn't do the job correctly. If something cooks your TIPM, are they going to cover the replacement cost or did you get any kind of warranty? I think Glenn has the best suggestion for you.
 

·
The Italian Admin
Joined
·
11,875 Posts
:wavey: Welcome to the ForumZ!
Sorry for your problem, but I'm sure you'll find all the help you need here. :smileup:
As Glenn suggested, check out the headlights supercenter
forum!
 

·
Registered
Joined
·
777 Posts
I would go back to where you had them installed and tell them about it. If it were done right there should have been no problems. I would be very up set about that. You did come to the right site for info and help though. Welcome.
 

·
Registered
Joined
·
2,532 Posts
I have read several posts elsewhere on the net
stating that installation of some HID kits have
caused the Caliber to burn out starters or the
car would try to start by itself.
 

·
Registered
Joined
·
3,588 Posts
Hello & welcome!!--- I think your pute is haunted by an HID Poltergiest !!!
 
1 - 12 of 12 Posts
Top