Dodge Caliber Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi Community,

My Dodge Caliber 2008 SE is having a power issue. The car drives normal and a sudden power drop comes twice or thrice in a week. When this happens while running starts with a power drop or a quick pullback feel. Then rpm will drop and won't rev according to the gas pedal. Car engine shuts off if stopped or at low speed. Check engine light will flash and stays in between. This rpm issue will be fine if I turn off the engine and restarts for twice. Comes again in another day or after a couple of starts. Sparks plugs were replaced (I believe it is done by the garage I go for maintenance) and a fuel injector cleaner applied. The issue is still there and attached is the dash video while this happens.

Video Link: video1.mp4

NB: Checked the error codes, and showing many codes, but nothing stays if we clear the codes. Also cleaned the throttle body with some gas put on it and started from the garage.

Please help on this, what can be the actual issue? Any power device failure or ignition issue like plugs or injector ??
 

·
Registered
Joined
·
683 Posts
Pretty much anything can cause symptoms like that, from a faulty throttle body to a failing fuel pump, so you need a mechanic to properly diagnose this one. I wouldn't suspect a faulty fuel injector since the failure of one will not cause the engine to act as you describe.

I would start the diagnosis at the throttle body as a failure of the electronics in it can cause these symptoms.
 

·
Registered
Joined
·
31 Posts
Hi Community,

My Dodge Caliber 2008 SE is having a power issue. The car drives normal and a sudden power drop comes twice or thrice in a week. When this happens while running starts with a power drop or a quick pullback feel. Then rpm will drop and won't rev according to the gas pedal. Car engine shuts off if stopped or at low speed. Check engine light will flash and stays in between. This rpm issue will be fine if I turn off the engine and restarts for twice. Comes again in another day or after a couple of starts. Sparks plugs were replaced (I believe it is done by the garage I go for maintenance) and a fuel injector cleaner applied. The issue is still there and attached is the dash video while this happens.

Video Link: video1.mp4

NB: Checked the error codes, and showing many codes, but nothing stays if we clear the codes. Also cleaned the throttle body with some gas put on it and started from the garage.

Please help on this, what can be the actual issue? Any power device failure or ignition issue like plugs or injector ??
When it happened to my 2008 SXT, it was a computer chip that went bad. About $800 years ago.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Pretty much anything can cause symptoms like that, from a faulty throttle body to a failing fuel pump, so you need a mechanic to properly diagnose this one. I wouldn't suspect a faulty fuel injector since the failure of one will not cause the engine to act as you describe.

I would start the diagnosis at the throttle body as a failure of the electronics in it can cause these symptoms.
Thanks Chris, yes my mechanic initially told me this, chances are more with the throttle body. Let me start with the throttle body and I hope that is causing the issue. I am afraid of the computer chip mentioned here by BROADNPATTISON. That is a lot of money.
 
1 - 5 of 5 Posts
Top