Dodge Caliber Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hello everyone, I used to be a member here. Went by Flyinghigh. My Caliber died in a head on in 2010 so I eventually became inactive. Anyway, I'm still in touch with two other former members, Licia and Teachair. Licia lives in Italy and Teachair lives in Poland. Teachair is looking for an OEM antenna for his 07 Caliber. If anyone has one they'd like to part with, please let me know. I'd buy it from you and send it on to Poland for him. I also placed a post in the Parts Wanted section of the forum. I still see a few Calibers on the road here in Alabama where I now live. Thanks.
 

·
Super Moderator
Joined
·
12,585 Posts
MykTurk
Registered · From Alton, IL USA, Earth
Joined Oct 14, 2007
Last seen Jul 5, 2020

Could you not get back in on FlyingHigh?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
MykTurk
Registered · From Alton, IL USA, Earth
Joined Oct 14, 2007
Last seen Jul 5, 2020

Could you not get back in on FlyingHigh?
No, I tried to, Aleks, but don't remember my password. I had two brain surgeries back in 2004 and as time goes on, my memory seems to be getting worse. I suffer from CRS and have to write everything down.
 

·
Super Moderator
Joined
·
12,585 Posts
Can't see a way to moderate your security. Do you still have the same email? If so there is a forgot option to reset the password.
 

·
Registered
Joined
·
2 Posts
Hello everyone, I used to be a member here. Went by Flyinghigh. My Caliber died in a head on in 2010 so I eventually became inactive. Anyway, I'm still in touch with two other former members, Licia and Teachair. Licia lives in Italy and Teachair lives in Poland. Teachair is looking for an OEM antenna for his 07 Caliber. If anyone has one they'd like to part with, please let me know. I'd buy it from you and send it on to Poland for him. I also placed a post in the Parts Wanted section of the forum. I still see a few Calibers on the road here in Alabama where I now live. Thanks.
Hi Flyinghigh (as you were known then). Think I may have joined before too (or is there another Cali forum). However, I just saw your post on an old thread concerning hard shifting 5- spd. manual. Some one brought up the matter that the problem seems to disappear by turning off the engine & that seems weird, as I've noticed the same thing, currently. It has to be that something somehow moves, and throws the worn cables off kilter.I'm betting that the 13 y-o linkages have rusted & should be replaced. Cheers, ojay.
 
1 - 10 of 10 Posts
Top