Dodge Caliber Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hi Guys, new here and couldnt find a thread on this one (although im sure it exists) please post a link if you can help...

I have a 2009 CRD SXT & love it:smileup:

Occassionally i was having the turbo cut out under load and after research here discovered it may have been an EGR Flow Control issue. As it was not a regular thing i kept driving it without missing much enjoyment from my sweet ride.

Last week i was away in the country for work and was clicking up the miles and putting the boot into the turbo topping 100 mph regularly...the turbo cut out several times & i reset it by turning the car off & on again

Until....

something changed!! Now it makes a really loud sucking noise when the turbo chimes in and if driving at a speed where the turbo is borderline it is hoppy jumpy rough....A hose leak? Intercooler issues?

I also had plumes of black smoke from the exhaust on acceleration since yesterday but have replaced the EGR today thinking these were all related but alas NOT!!

I have solved the black smoke edit... still have the black smoke :( and turbo cutting out under load by replacing the EGR (collective thanks goes to caliberforumz) BUT my loud turbo sucking noice and jumpy RPMs around 2,000 was unrelated:smiledown:

would love some help
 

·
The Organizer
Joined
·
15,004 Posts
Sounds like a wastegate issue.
 

·
Registered
Joined
·
8,302 Posts
Another member, from either the UK or Australia, had a similar issue.
Turned out one of the main air hoses in the turbo system was split. I think it was the hose from the intercooler to the throttle body. Might be worth a look.
 
1 - 4 of 4 Posts
Top