Dodge Caliber Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello all, I have had my 2007 SXT Caliber for around 2 years now. Out of the blue it just started acting like it was going to stall at random speeds. It almost stalls then the RPM's jump and catch me up. Looking at this Awsome site I found that my car needs the TSB 18-031-07 upgrade....So on next Wen. I will be takeing my car to the dealership to get this done. My question is....is there any updates to this TSB that you may know of.....I like to go into dealerships knowing everything that I can. Also, if you had this same problem and got this update did it fix everything. Or was there more to be fixed...?
 

·
Registered
Joined
·
3,985 Posts
Your dealer will take care of bringing your ECU as up-to-date as it can get. This might take care of a number of TSBs regarding available flash corrections.

Other than that, through your VIN, the dealer will be able to tell what TSB has been applied already, if any, and which need to be done.
 

·
The Organizer
Joined
·
15,005 Posts
Hello all, I have had my 2007 SXT Caliber for around 2 years now. Out of the blue it just started acting like it was going to stall at random speeds. It almost stalls then the RPM's jump and catch me up. Looking at this Awsome site I found that my car needs the TSB 18-031-07 upgrade....So on next Wen. I will be takeing my car to the dealership to get this done. My question is....is there any updates to this TSB that you may know of.....I like to go into dealerships knowing everything that I can. Also, if you had this same problem and got this update did it fix everything. Or was there more to be fixed...?
As mouser posted, the dealer will bring the software up to the latest version. This TSB will not correct what you describe. Your issue sounds more like spark plugs. When, if at all were they replaced? You have to diligently replace them every 30K miles.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Thanks guys, I guess that I just have to wait and see from the dealer....As for the spark plugs. This problem has been happening for about a week to two weeks off and on. About 3 days into it I changed my spark plugs to double platnums, changed the airfilter and added seafoam (Fuel inj cleaner) to the gas. I figured I bought a bad tank of gas. But the problem still there...
 
1 - 4 of 4 Posts
Top