Dodge Caliber Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello, I have just joined the group and I was wondering if any of you could help me with this couple of issues I have with my car. Is a 2007 RT with 110k miles. First I find that it is leaking coolant which I suspect is from the filler neck I just ordered one, lets see if that fixes it. Second the idle issue, it's getting worse. I might change the spark plug and the PCV valve in a couple of weeks (once I have some money). Do any of you have more suggestions on that? It basically tries to stall at low RPMs, not all the time but every so often maybe twice per trip of something like that.
 

·
Registered
Joined
·
81 Posts
Rough idle can be tough to diagnose. I'd eliminate the things you can do for free first:

Clean the throttle body - take it off and really give it a good cleaning
Clean PCV valve (don't bother replacing unless it is obviously broken)
Looks for vacuum leaks (consider paying for a smoke test if nothing else works)
Pull the plugs and see if they are all burning cleanly

I have a 2007 Caliber R/T manual transmission race car. It came to me with idle issues and I did get them fixed, but I don't know what fixed it because we did all of the above plus replacing all the engine sensors, fuel injectors, coil packs, plugs, and more. One or more of those things did fix the issue...
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Rough idle can be tough to diagnose. I'd eliminate the things you can do for free first:

Clean the throttle body - take it off and really give it a good cleaning
Clean PCV valve (don't bother replacing unless it is obviously broken)
Looks for vacuum leaks (consider paying for a smoke test if nothing else works)
Pull the plugs and see if they are all burning cleanly

I have a 2007 Caliber R/T manual transmission race car. It came to me with idle issues and I did get them fixed, but I don't know what fixed it because we did all of the above plus replacing all the engine sensors, fuel injectors, coil packs, plugs, and more. One or more of those things did fix the issue...
Thanks I will try those things you mentioned first. Thanks
 
1 - 4 of 4 Posts
Top