Dodge Caliber Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello all I have a 2009 SXT, I’ve been having problems with the vehicle when you try putting it into or out of park sometimes. You have to push the shifter lock override on the side and then you can shift into/out of park. Sometimes it gets stuck in park and you have to do the same thing to get it into drive. Took apart the shifter column and you can see the mechanism working while the brake is pressed. Also the shifter bushing looks good. The problem is only intermittent so I’m not sure what’s going on. Thanks for any advice!
 

·
Registered
Joined
·
90 Posts
Hello all I have a 2009 SXT, I’ve been having problems with the vehicle when you try putting it into or out of park sometimes. You have to push the shifter lock override on the side and then you can shift into/out of park. Sometimes it gets stuck in park and you have to do the same thing to get it into drive. Took apart the shifter column and you can see the mechanism working while the brake is pressed. Also the shifter bushing looks good. The problem is only intermittent so I’m not sure what’s going on. Thanks for any advice!
That 's your problem easy fix for me.
 

Attachments

·
Registered
Joined
·
277 Posts
We should focus into just one post for clarity, and stay on this link

 

·
Registered
Joined
·
90 Posts
Hello all I have a 2009 SXT, I’ve been having problems with the vehicle when you try putting it into or out of park sometimes. You have to push the shifter lock override on the side and then you can shift into/out of park. Sometimes it gets stuck in park and you have to do the same thing to get it into drive. Took apart the shifter column and you can see the mechanism working while the brake is pressed. Also the shifter bushing looks good. The problem is only intermittent so I’m not sure what’s going on. Thanks for any advice!
Sorry I forgot to mention that I have already replaced the neutral safety switch.
Well i had the same Issue with my Caliber doing the same thing you are doing everyday.I order one that I thought would work off Amazon must had a defect went to my local Pull Apart and got one off of a car there got home put it on made the adjustments making sure it was going through the right gears Problem Solve It's been over a year now.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Well i had the same Issue with my Caliber doing the same thing you are doing everyday.I order one that I thought would work off Amazon must had a defect went to my local Pull Apart and got one off of a car there got home put it on made the adjustments making sure it was going through the right gears Problem Solve It's been over a year now.
Thanks for the reply. I tried a brand new NSS which didn’t fix the issue so had one from a pick a park car and same thing. I don’t think it’s the NSS
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top