Dodge Caliber Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My car runs normally for about a minute then loses power at idle and will sometimes stall. But if I just restart it after waiting a few seconds it runs normally again and for abit longer. I noticed when I got the car at the end of winter last year it would do it sometimes. Then in the summer it completely stopped happened and I forgot about it. I think it maybe happened once during that time. But once it got colder the problem started to happen more and more often. Still runs just have to pull over and restart the car often.

I've replaced the throttle body as my dad thought that could be the problem. After that the car ran a little better but the problem kept happening. We used his scanner and it says there's a HVAC system leak? And that's about it. We can't find the problem and I can't really afford a mechanic rn. But might have to consider it
 
Joined
·
1 Posts
My car runs normally for about a minute then loses power at idle and will sometimes stall. But if I just restart it after waiting a few seconds it runs normally again and for abit longer. I noticed when I got the car at the end of winter last year it would do it sometimes. Then in the summer it completely stopped happened and I forgot about it. I think it maybe happened once during that time. But once it got colder the problem started to happen more and more often. Still runs just have to pull over and restart the car often.

I've replaced the throttle body as my dad thought that could be the problem. After that the car ran a little better but the problem kept happening. We used his scanner and it says there's a HVAC system leak? And that's about it. We can't find the problem and I can't really afford a mechanic rn. But might have to consider it
I recently had a similar experience. I have since changed the spark plugs and injectors however it still stalls at idle from time to time.
 
1 - 2 of 2 Posts
Top