Dodge Caliber Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
picked up a 08 with 111.xxx on it got the rough idle in park and at stop lights no code's or check engine light's at all
change plug's no change. change 2 coils no change. any way to tell if coil's are bad? thanks
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #4 ·
i cleaned the throttle body did not help motor mount's look to be new all of them. it's real bad when in gear at stop light shake's bad but run's grate when u get moving i did run some sea foam in the tank helped some. i can hear all injectors working no check engine light or code at all thanks
 

·
Registered
Joined
·
762 Posts
If you're in parked and the car is running, does it smooth out if you rev the engine up to 2000RPM or so and hold it there?

Almost sounds like a lean/rich fuel issue at idle, like the car is running lean for some reason but when driving more fuel is entering the system, thus smoothing things out
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
yes in park i can rev it to the moon....and hold it the sea foam i put in the tank did help some
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #10 ·
ok thanks i stated it today it flashed like 3 or 4 time's so had to call in to work dam money pit lol
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #11 ·
well i put a new throttle body on it fri oct 29th worked good a till today 11/2/21 started it up to warm up. go outside its running funny i can hear it through tail pipe get in side that dam flashing lighting bolt is flashing car wont rev up turn it off and back on runns good wtf is going on with this
 

·
Registered
Joined
·
8 Posts
well i put a new throttle body on it fri oct 29th worked good a till today 11/2/21 started it up to warm up. go outside its running funny i can hear it through tail pipe get in side that dam flashing lighting bolt is flashing car wont rev up turn it off and back on runns good wtf is going on with this
Did you try to reset the adaptive memory after installing the new throttle body?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #16 ·
i reset it ver vid it did not work. drove it 3 blocks light stated to flash started to jurk car went into lip mode.made it back home
 

·
Registered
Joined
·
762 Posts
What BRAND of throttle body did you buy? You definitely need to go OEM with anything electrical...aftermarket electricals are hugely problematic
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #18 ·
well guys took it to dealer. it had a intake leak so i put on new intake gasket on and new throttle Body gasket .its about 80% better still rought idle in gear at stop light..also hooked up smoke machine. no leaks has. new plugs and 2 new coils. what next? runs great on hiway.
 

·
Registered
2007 Dodge Caliber SXT 1.8L 5 speed w/248k
Joined
·
4 Posts
Im having the same issue. Only when its cold or low humidity. Its currently -40°C/°F here in Saskatchewan. The intake manifold gaskets tend to shrink causing it to have a vaccum leak. And cause it to go into limp mode. Try spraying TB cleaner or ether right around the intake manifold gasket. If it causes a change in rpm, then thats your issue
 

·
Registered
2007 Dodge Caliber SXT 1.8L 5 speed w/248k
Joined
·
4 Posts
Sorry just seen the last comment, it didkt finish loading the whole thread b4 i startes typing and my phone shuts itself off when it gets cold so had ro type fast.
 
1 - 20 of 20 Posts
Top