Dodge Caliber Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all,
Been having power issues for a couple months and every time it’s p0700, which doesn’t tell you anything specific. The biggest issue I have and when it pops up is while reversing, which was the first time it happened, all power just cut off everywhere. Second time I was pulling onto a main road without applying gas and halfway thru the turn all power went out. Luckily this was at 1am with no traffic. Third time I was going over some dips at a gas station and every time it shook battery light blinked on, I cleared the dips and 10 feat Later lost all power.
Today it happened again 3 different times once right after I reverse parked, took my keys out, and everything went dead. Went to Auto Zone, battery and alternator both 100 percent despite battery taking a bit of extra charge past 100%. Couldn’t figure it out, so I got in my car to go home put my keys in... all power dead. Whenever this happens I just disconnect and reconnect battery and it powers on again so I did that. But this time after I did that I went in the car turned the key with everything fine but right before it cranked... dead. Had to go back out, and being tired of unfastening and fastening so many times I taped the positive terminal twice inwards from the side and power came back on. Went to start it and it started.
Now here’s the thing, I’m trying to sell this car, like I have a buyer fuming at the mouth to buy it, but I can’t for the life of time sell it to him b4 figuring out why is going on. And during the past couple weeks the first crank has been extremely rough and deafening lots of grinding action and not the sexy kind. So please anyone with any info help a brother out. I’ve deduced that it’s likely a short or loose part somewhere, but I’d like more info b4 taking it to mechanic/dealership and maybe see if it’s something I can fix myself.
Thank y’all in advance.
 

·
Registered
Joined
·
645 Posts
Check the battery negative cable where it attaches to the body of the car...if there's a bad connection to the frame it could cause the car to die like that.
 
1 - 2 of 2 Posts
Top