factory radio acting up
Results 1 to 5 of 5
  1. #1
    Join Date
    Jun 2006
    Location
    Birthplace of the Modern Auto Industry
    Posts
    155
    Rep Power
    12

    Default factory radio acting up

    2011 Express with the factory sirius radio. its a better radio than the one in my dads '07 sxt...

    a couple of times now, upon start up, it has no power. no display. yesterday when it happened there was no dash display (odometer warning lights) either...

    after a couple of "restarts" it finally came back online, but now i have only about a 30-70 distribution between left and right speakers. the adjuster is set for 50-50 equilization...

    has anyone had issues like this?

  2. #2
    Join Date
    Feb 2012
    Location
    Rochester NY
    Posts
    269
    Rep Power
    6

    Default

    If the instrument panel and the radio are both acting up, then there's likely some sort of common issue that's affecting them both. I looked at the wiring diagrams and lo and behold, both the instrument cluster and radio share a common ground...G250 (though the IC also uses G200). Locate and check that ground to make sure it's not loose or corroded.

  3. #3
    Join Date
    Jun 2006
    Location
    Birthplace of the Modern Auto Industry
    Posts
    155
    Rep Power
    12

    Default

    thanks!

    ill look for that

  4. #4
    Join Date
    Sep 2008
    Location
    London
    Posts
    11,942
    Rep Power
    28

    Default

    I don't know how to physically locate a specific ground point but also be aware of the poor quality and exposed wiring loom. The routing may also be common and have damaged insulation.
    replaced - hub bolts, warped rotors, 3 batteries, 2 screens, 12 alloy wheels, seat cover, armrest, Track-rod ends, clutch master cylinder, LH tail unit, LCAs, rear toe link,

  5. #5
    Join Date
    Feb 2012
    Location
    Rochester NY
    Posts
    269
    Rep Power
    6

    Default

    The service manual shows the location of the various grounding points (as well as all of the electrical connectors and wiring harnesses and the such). Good stuff!

    The diagram shows G250 to be inside the car, front passenger area, at the top back right corner of the dashboard. I suspect (but don't know for sure) that if you remove the trim piece that covers the A-pillar on that side, you *might* see the grounding point. Otherwise, it could be quite a challenge to find it.

    As Aleks said, it could also be a problem with chaffed/shorted wiring elsewhere. The usual culprit (harness behind driver's front wheel well shield) is worth a look too.

    g250.pdf

Similar Threads

  1. Sxt factory radio help
    By Lreiland in forum Custom Dodge Caliber Interior Modifications - Audio / Video
    Replies: 1
    Last Post: 10-24-2016, 11:09 AM
  2. Caliber Factory Radio
    By Kingmopar in forum Custom Dodge Caliber Interior Modifications - Audio / Video
    Replies: 10
    Last Post: 07-10-2014, 09:05 AM
  3. Factory sat radio
    By evoone303 in forum Custom Dodge Caliber Interior Modifications - Audio / Video
    Replies: 5
    Last Post: 02-05-2013, 01:36 PM
  4. Need assist. w/ amp install to factory radio
    By maydayfighter in forum Custom Dodge Caliber Interior Modifications - Audio / Video
    Replies: 3
    Last Post: 11-04-2012, 09:16 PM
  5. Factory Sat. Radio ????....
    By Quickerthanu in forum Custom Dodge Caliber Interior Modifications - Audio / Video
    Replies: 9
    Last Post: 08-27-2008, 07:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •